Jump to content
vortecjr

SGC - sonicTransporter & HQPlayer 4 Embedded upsampling UPnP, Tidal, and Qobuz streams

Rate this topic

Recommended Posts

This week I have been testing a Small Green Computer i5 sonicTransporter music server running Singalyst HQPlayer 4 Embedded to upsampling UPnP streams, Tidal streams, and Qobuz streams. The resampled and filtered stream is then sent to my ultraRendu via the NAA protocol. In this configuration HQPlayer 4 Embedded show up as a UPnP renderer making it very easy to send streams to it from your favorite DLNA/UPnP controller and server. Enabling HQPlayer 4 Embedded as an OpenHome renderer with BubbleUPnP Server then also you to stream Tidal and Qobuz via an application like Kazoo. In the next post I'll show you how to configure this feature.

Share this post


Link to post
Share on other sites

Prerequisites

Knowing how to use HQPlayer 4 Embedded on a sonicTransporter is a requirement and beyond the scope of this how to guide. For additional information on using HQPlayer 4 Embedded refer to this post:

https://www.computeraudiophile.com/forums/topic/38918-sgc-sonictransporter-series-and-signalyst-hqplayer-4-embedded/?page=1

 

Tests Conducted to Date 

1. Tidal streams at 44.1 via Kazoo 

2. PCM and DSD streams via MinimServer

3. JRiver streaming PCM (does not require OpenHome)

 

Configure the micro/ultraRendu

Software Installation

1. Go to Apps / App Switcher and select HQ Player NAA.

58cd99fba09c9_ScreenShot2016-11-18at5_33_00PM.png.c4a9cb9cb733c3e0e14670c163a00ed7.png

 

Configure the SonicTransporter

Software Installation

1. Go to Apps / Software manager and install BubbleUPnP Server.

2. Go to Apps / Software manager and install HQ Player Server.

 

Software Setup

1. Go to Apps and select BubbleUPnP Server to configure it. When prompted about Internet connectivity make your selection and press Ok. From the Media Renderers tab select sonicTransporter from the left side of the page and configure it as follows:

Screen Shot 2018-05-01 at 6.38.54 PM.png
 

2. Go to Settings / HQ Player Server / HQ Player Config and configure HQ Player to resample per your preferences. Remember to select the micro/ultraRendu as the NAA output device at the bottom of the HQ Player Configuration screen under Network Audio Backend.

5ae8f2241ab79_ScreenShot2018-05-01at7_01_58PM.thumb.png.731f378262700e04f7b708ef41a0c3f7.png

 

Configure your DLNA/UPnP Controller

Here is how thing looks from the Kazoo controller.

5ae8f316d9371_ScreenShot2018-05-01at7_06_31PM.thumb.png.5ae4610f3465492c4c51a9b8fe36376f.png 

Share this post


Link to post
Share on other sites

When I install HQ Player and BubbleUPnP on the sonic transporter (version 2.7), I don't see the sonicTransporter in the Media Renderers list. Any idea what I'm doing wrong?

Thanks

Share this post


Link to post
Share on other sites
2 hours ago, wmfrog said:

When I install HQ Player and BubbleUPnP on the sonic transporter (version 2.7), I don't see the sonicTransporter in the Media Renderers list. Any idea what I'm doing wrong?

Thanks

You have to have a NAA device selected and ready to play to before it will list it. 

Share this post


Link to post
Share on other sites

My microRendu was in MPD DLNA mode so from App Switcher I selected NAA. From sonicTransporter I open the HQ Player E configuration and selected the microRendu and hit Apply. This is what I see in BubbleUPnP Server.

 

Screen Shot 2018-10-16 at 6.37.02 AM.png

Share this post


Link to post
Share on other sites

Thanks again JR. Something is funky.

I reinstalled BubbleUPnP and HQ Player Server.

I can now select the UltraRendu in the HQ Player config screen.

But I don't see the UltraRendu or the SonicTransporter in the BubbleUPnP Server Media Renderer list.

There are some older comments of people with this problem in earlier versions of HQ Player, but I don't find any current fix.

Share this post


Link to post
Share on other sites

Right, but I'm trying to see the SonicTransporter  and your step 1 above is to put the Rendu in HQPlayer NAA mode. I'm at a loss why I can't see the Sonictransporter. I can see other renderers on my network.

Thanks

 

Share this post


Link to post
Share on other sites
On 10/16/2018 at 8:01 PM, wmfrog said:

Right, but I'm trying to see the SonicTransporter  and your step 1 above is to put the Rendu in HQPlayer NAA mode. I'm at a loss why I can't see the Sonictransporter. I can see other renderers on my network.

Thanks

 

I’m not sure. Contact Andrew and maybe he can log into your machine and see what is going on.

Share this post


Link to post
Share on other sites

Talked to Jesus this morning.

Try this

 

1. Go into Apps / DAC Diagnostics on the ultraRendu and make sure your DAC is there.
2. Go into Apps / App Switcher on the ultraRendu and select NAA.
3. Go into Settings / HQplayer Config on the sonicTransporter and make sure the ultraRendu is selected as the NAA player.
4. It should now show up in BubbleUPnP Server.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×