Jump to content
Computer Audiophile
jtwrace

Allo Sparky USBridge

Recommended Posts

Facel   
8 hours ago, tkr001 said:

To those having trouble with raspotify and the Allo USBridge try this:

...

@tkr001    Thank you very very .very much .. I have been trying many different syntaxes for this parameter without any success

(hw=1, hw=0  ...) Spotify is now running perfectly

 

by the way ... do you know how to set the parameter in order to have  an autostart for

1) Desktop (LXDE)

2) VNC4

3) Jriver

 

My problem is to launch the VNC with every parameters in order to be able to run the Sparky headless and to be able able to

access  it remotly if needed.

 I did not succeed to have the correct parameter set in the "custom" autostart otpion in dietpi-config

best regards

 

 

 

Share this post


Link to post
Share on other sites
2 hours ago, jtwrace said:

I downloaded v6.1 and the GUI doesn't work anymore, is this correct?  Can't login with my static IP but it shows up in Roon.  

Web interface passed local testing.

Can you confirm:

- SBC device used

- IP address of the system

- URL used to access web interface (should be http://IP)

Share this post


Link to post
Share on other sites
jtwrace   
10 minutes ago, Daniel Knight said:

Web interface passed local testing.

Can you confirm:

- SBC device used

- IP address of the system

- URL used to access web interface (should be http://IP)

Sparky SBC

10.0.1.104

Yes, in the past I just enter the above and it works but it's not now after the update.

Share this post


Link to post
Share on other sites
37 minutes ago, jtwrace said:

On second thought, is there any software that I need to install other than Roon for web access? 

The Allo GUI is only pre-installed with the Allo GUI images:

http://dietpi.com/phpbb/viewtopic.php?f=8&t=2317&p=8869#p8869

Did you use the stock DietPi image (http://dietpi.com/download) or one from the above link?

Share this post


Link to post
Share on other sites
Lobbster   

Success V6.1 working - I flashed one of my units and everything works great as before. I filed out the MicroUSB port on the aluminum case and will post some pics shortly.

 

@Daniel Knight

I notice the Swap FIle size is disabled. This is a change from the prior build. Is it ok ?

I don't know what to look for in the change log.

Share this post


Link to post
Share on other sites
Lobbster   

Here's some pics of the MicroUSB port modification I made. I'm using a Ghent Audio split MicroUSB/DC Plug cable running off a 5V/50A R-Core LPS I purchased off AliExpress . I just used a basic hand file you can see in several pics. Aluminum is easy to work with.

 

 

P2040424.jpg

P2040425.jpg

P2040426.jpg

P2040428.jpg

P2040431.jpg

P2040432.jpg

IMG_9163.jpg

Share this post


Link to post
Share on other sites

I have a problem I am hoping someone can help me with:

 

 I flashed the eMMC using Etcher to install version 6.1, and successfuly opened the GUI and noted the new version, and successfully played music using Audirvana. I then tried the USB-Ethernet dongle plugged into the USB 3.0 port on the side of the Sparky, and again successfully played music using Audirvana.

 

However Something went wrong, not sure what, so I retraced my steps, reinstalling using Etcher, and now it will not connect to the network on boot up. I have tried reinstalling multiple times but no luck. I see network activity briefly while booting up then nothing and the Sparky red light goes off. 

 

In the past reflashing was the cure all, but not now. Any my help with this would be greatly appreciated.

 

John

 

 

Share this post


Link to post
Share on other sites
jtwrace   
19 hours ago, Daniel Knight said:

The Allo GUI is only pre-installed with the Allo GUI images:

http://dietpi.com/phpbb/viewtopic.php?f=8&t=2317&p=8869#p8869

Did you use the stock DietPi image (http://dietpi.com/download) or one from the above link?

Yet again I'm so confused.  Can you post a direct link to the actual download that I need to install?  These downloads show 9/2017 and I thought what I need is something recent?  

Share this post


Link to post
Share on other sites
MagnusH   

Hi guys

 

I have a Pro-Ject Pre Box S2 DAC connected to a iFi nano iUSB3 and then to computer. Between the DAC and iFi nano iUSB3 I have a USPCB A>B connector from UpTone. I also have a 5v 25w linear power that powers the DAC (and a iFi iPower 5V that is not used).

 

This setup sounds good, but I am thinking that replacing the iFi nano iUSB3 with an USBridge would be even better. I use Roon to play music.

 

Some questions:

1. Does USBridge work with the Pro-Ject S2 DAC? DSD native?

2. If I bought an USBridge, how to best set it up? With or without the iFi nano iUSB3? Separate power to the 2 parts in USBridge (as I mentioned, I have an 5v iFi iPower not used)? Power the DAC over USB from USBridge, or with separate power?

3. Which OS would be best to use for me?

4. Is it worth it? Will I get a noticeable increase in SQ? I have a $4000 system in an acoustic treated room.

 

Thankful for some help!

Share this post


Link to post
Share on other sites

Hi again,

 

Solved my problem with the USBridge failing after a EMMC reinstall. My desktop computer literally failed just after what was apparently a bogus reinstall, totally kaput--after 10 years of faithful service! I started out again with the laptop and all is well.

 

John

Share this post


Link to post
Share on other sites

I use daphile to push music to allo's sparky + usbridge,but squeezelite can not output pcm24/192 and dsd128,my dac is holo audio's spring.

when i use volumio,my allo's sparky + usbridge can output pcm24/192 and dsd128.i notice the version of suqeezelite in dietpi of allo is 1.8.7.1020,the new

On 2018/2/5 at 4:19 AM, Daniel Knight said:

The Allo GUI is only pre-installed with the Allo GUI images:

http://dietpi.com/phpbb/viewtopic.php?f=8&t=2317&p=8869#p8869

Did you use the stock DietPi image (http://dietpi.com/download) or one from the above link?

est is 1.8.7.1052,Will squeezelite how to solve this problem?

Share this post


Link to post
Share on other sites
PunkRiot   
16 hours ago, MagnusH said:

 

1. Does USBridge work with the Pro-Ject S2 DAC? DSD native?

2. If I bought an USBridge, how to best set it up? With or without the iFi nano iUSB3? Separate power to the 2 parts in USBridge (as I mentioned, I have an 5v iFi iPower not used)? Power the DAC over USB from USBridge, or with separate power?

3. Which OS would be best to use for me?

4. Is it worth it? Will I get a noticeable increase in SQ? I have a $4000 system in an acoustic treated room.

 

Thankful for some help!

1. Yes it works pretty well. No DSD native. 

2. I prefer simple solutions. No iUSB3. Feed USBride using LPSU, if you want you can also use IFI as separate power for SParky board. (You will have to open Jumper 28 in case of dual power supply). Use battery or LPSU for Project DAC.

3. I use DietPi with Allo GUI. Easy setup.

4. It is always worth to remove your computer from acoustic treated room. I am not sure if it will improve SQ, however the whole setup will be smaller, easier, and dead silent. (not sure if you computer is fan-less now). 

Share this post


Link to post
Share on other sites
PunkRiot   
22 hours ago, jtwrace said:

Yet again I'm so confused.  Can you post a direct link to the actual download that I need to install?  These downloads show 9/2017 and I thought what I need is something recent?  

I downloaded from this link two days ago, this was 6.1 with Allo GUI.

7z file under this link is updated on regular basis so yo will have the newest Allo GUI image there:

Download Image:

Share this post


Link to post
Share on other sites
jtwrace   
1 minute ago, PunkRiot said:

I downloaded from this link two days ago, this was 6.1 with Allo GUI.

7z file under this link is updated on regular basis so yo will have the newest Allo GUI image there:

Download Image:

THANK YOU!  

 

I don't get why it's so hard to have a direct link for these downloads.  

Share this post


Link to post
Share on other sites
ambre   

Hi Daniel & Rahul,

 

Downloaded and flashed latest image 6.1. incl Allo GUI this afternoon. 

 

I am not able to play HiRes files anymore. Only 44.1 or 48.0 kHz format.  Problem : Not succeeding to handshake my DAC TEAC 501 to play PCM 352 or preferably DSD 128 by means of HQ-player or Roon Core. Ps.   It doesn't matter which kind of sequence starting. i.e. Allo Sparky first or my DAC first. Including starting Roon and HQ-player. 

 

The same issue as last week when  rahul_kc  has  sent me a PM to execute some Linux commands. which is quite inconvenient due to the fact I am using a headless Mac mini.  And I was under the assumption that this was solved in Version 6.1. 

 

This kind of practice highly disturbing. Back to Version V159 which runs 60% of time as it belongs.:(

 

In awaiting your reply.

Regards, Andreas

Share this post


Link to post
Share on other sites
PunkRiot   

@ambre if you can access USBridge via ssh check this command: cat /DietPi/uEnv.txt

 

And see what is the setting at the end of: aotg.aotg1_speed

Is it 0 or 1? I belive in your case to work properly with USB Audio 2 it should be set to 0.

Share this post


Link to post
Share on other sites
ambre   

Thanks PunkRiot, 

 

I am a layman in this area and........ I do not really know how this works.  Can you access this also from the Allo GUI B|?

 

IMO USB 2.0 is the present standard for USB DAC incl streaming !  Why is this not set by default?

 

Regards, Andreas

Share this post


Link to post
Share on other sites
7 minutes ago, ambre said:

Thanks PunkRiot, 

 

I am a layman in this area and........ I do not really know how this works.  Can you access this also from the Allo GUI B|?

 

IMO USB 2.0 is the present standard for USB DAC incl streaming !  Why is this not set by default?

 

Regards, Andreas


It's not possible to access this file from the Allo GUI.

If you have a Mac you can access it via terminal, with a PC you have to install Putty: https://mediatemple.net/community/products/dv/204404604/using-ssh-in-putty-

In your terminal window type:

ssh root@dietpi
Password = dietpi

Once your logged in SSH into diet pi type the command:
nano /DietPi/uEnv.txt

Check the end of the second line of the text file. I had to scroll along manually to do this. You are looking for “aotg.aotg1_speed value”. The speed value needs to be set to 0 for 32 bit USB 2.0 DACs. If you’re using a dragonfly or other USB 1.1 DACs it should be set to 1. The last line should look like this… $d/systemd aotg.urb_fix=1 aotg.aotg1_speed=0 Exit and save the file then reboot the system. You should then be back in business! 

Share this post


Link to post
Share on other sites
rahul_kc   
55 minutes ago, ambre said:

Thanks PunkRiot, 

 

I am a layman in this area and........ I do not really know how this works.  Can you access this also from the Allo GUI B|?

 

IMO USB 2.0 is the present standard for USB DAC incl streaming !  Why is this not set by default?

 

Regards, Andreas

Hi @ambre

 

you can download dietpi v6.1 Image from  https://goo.gl/VNs6yg

On this aotg.aotg1_speed value set to 0 always by default.

I have asked the linux commands results for checking the hardware.

 

Share this post


Link to post
Share on other sites
rahul_kc   
On 06/02/2018 at 5:11 PM, PunkRiot said:

1. Yes it works pretty well. No DSD native. 

2. I prefer simple solutions. No iUSB3. Feed USBride using LPSU, if you want you can also use IFI as separate power for SParky board. (You will have to open Jumper 28 in case of dual power supply). Use battery or LPSU for Project DAC.

3. I use DietPi with Allo GUI. Easy setup.

4. It is always worth to remove your computer from acoustic treated room. I am not sure if it will improve SQ, however the whole setup will be smaller, easier, and dead silent. (not sure if you computer is fan-less now). 

Hi  @PunkRiot

 

USBridge driver modified to support  Native DSD on Pro-Ject Pre Box S2 DAC.

details available on below link.

https://github.com/sparky-sbc/sparky-test/tree/master/pro-ject-s2

 

Share this post


Link to post
Share on other sites

×