Jump to content
vortecjr

Sonicorbiter - Spotify Connect output mode (beta)

Rate this topic

Recommended Posts

16 hours ago, R1200CL said:

Thanks.  I tried the procedure and gave the microRendu a DHCP Reservation, but the IP address did not change after the modem restarted. 

Share this post


Link to post
Share on other sites
On 6/4/2017 at 6:05 PM, mttbsh said:

I too am no longer able to use the Spotify Connect app. Even when I select Spotify Connect in My SonicOrbiter, the Microrendu is either not listed as one of my devices in Spotify or Microrendu is listed but when I click on it, it will not highlight as all of the other devices will. 

 

Same issue here.

Share this post


Link to post
Share on other sites

Now you can update, reboot, then go into Settings/Spotify Connect and press Save. I'm going to designate this application beta for the time being.

Share this post


Link to post
Share on other sites

Just tried to use connect for first time and mU doesn't show up on under "Connect to a Device".

 

I typically use ROON with HQP and mU as NAA (which is working fine).  Running 2.5 OS and latest Spotify version on office wkst (not HQP wkst). 

1. I went into app switcher, selected Spotify connect > Save

2. Restarted

3. Restarted Spotify on office wkst, no go

4. Fired up Spotify on iPhone and shows up under available devices on office wkst.

5. mU has always had reserved DHCP

 

Any ideas?

Share this post


Link to post
Share on other sites
12 hours ago, vortecjr said:

Did you update, reboot, then go into Settings/Spotify Connect and press Save?

Just tried that, still no go?

Share this post


Link to post
Share on other sites
2 hours ago, vortecjr said:

You need a premium account and you need to enable High Quality Streaming. 

Screen Shot 2017-06-10 at 9.14.56 PM.png

Yep I have a prem account and enabled HQ setting, weird.  Not sure what else to try

Share this post


Link to post
Share on other sites

I was also struggling with this, but then I found that "High Quality Streaming" had somehow toggled off in Spotify,

Share this post


Link to post
Share on other sites

Installed Spotify on another system (my ROON controller 2 in1 laptop) made sure high quality is enabled and still no go, nothing shows up under devices?

 

Share this post


Link to post
Share on other sites
On 6/12/2017 at 7:41 PM, Foggie said:

Installed Spotify on another system (my ROON controller 2 in1 laptop) made sure high quality is enabled and still no go, nothing shows up under devices?

 

Any other solutions or things to try would be appreciated, as I am still unable to get connect to work

Share this post


Link to post
Share on other sites
21 hours ago, vortecjr said:

Nothing on my end to suggest.

Is this a spotify, sonicorbiter or network issue?  Are there any logs that can be complied/used? 

 

Being all the other devices I have on my network with spotify installed (several iPhones, ipads, laptops, one 2 in 1, and wkst) all show up under connect. Trying to understand how there are no other troubleshooting methods to use for this issue.

Share this post


Link to post
Share on other sites

I installed the new Sonic Orbitter card and tried Spotify Connect.  

 

Spotify sees the microRendu from the select device screen, but when I select it, the screen says connecting, but never connects - it just reverts back to the mobile device.

 

Any ideas?

Share this post


Link to post
Share on other sites
On 6/26/2017 at 6:35 PM, vortecjr said:

This is a long shoot: From Apps / Software Manager remove the application, reboot, and then install the application again.   

Thanks for the suggestion, and I was really hoping this would work, but unfortunately still no go.  I also made sure to perform a save settings as well as reboot several times. 

 

While in Spotify on wkst, as soon as I launch the Spotify app on iphone the connect lights up immediately.  I made sure to watch the "connect" icon (on wkst) closely while rebooting mU and saving changes to see if the connect icon lit up briefly but never noticed any activity :(  

 

Too bad and is really unfortunate this won't work in my environment since clearly the "connect" technology is working, just not with the mU. 

 

I can try a dumb switch and remove the fiber when I have a min since there are issues with mU using these components (managed switches/fiber).  Although I have no issues with anything else in my network with my current topology.

Share this post


Link to post
Share on other sites

 

On 6/7/2017 at 2:10 PM, JMotzi said:

In case others encounter a similar problem as I had......

 

I recently needed to re-install Windows 10 on my PC due to a boot disk issue.  After this, I could not get the microRendu to recognize my DAC.  I tried all the usual rebooting, etc of computer, DAC, MR, etc multiple times and even shut down the MR for a day but was getting nowhere.  I knew it was not the DAC because I could hook up the same USB cable directly to it and play general audio output.  I knew it was not network connectivity because I could communicate just fine with the MR.  Also everything seemed to check out regarding agreement of IP & MAC addresses on my router, Cisco switch, etc. and all of the usual devices showed up on the network - it's just that the DAC Diagnostics test on the MR failed every time over the course of a few days.  In the end I right clicked on the microRendu player icon (the media device with the green arrow) in my Network panel and noticed that there was an option to enable streaming.  I did enable that and voila everything starting communicating just fine.  I don't remember doing that on the original install (under Windows 7), but this was definitely the solver of my connectivity problems (or just a large coincidence).  Perhaps this is well known to others but it wasn't known to me.

 

JM

 

On 6/7/2017 at 6:37 PM, JMotzi said:

Hi R1200CL - I am currently on the road without a Windows machine so no screen shot - sorry.  In Windows, under the file explorer, one can show all network connections;  In the Media Player section of that screen there are icons with blue musical notes which indicate servers and other icons with green arrows representing players.  What I needed to do was enable permission for streaming on the microrendu icon.  When I initially installed the device (one of the early adopters) under Windows 7, it took me about 10 minutes at most and I don't remember having to do anything with permissions.  When I migrated to Windows 10, everything was automatically ported and no adjustments were required.  microRendu on my PC has always been solid, never temperamental.  I listen with it daily.

 

The issue here that required solving seems to be a pure OS issue and probably not specific to the MR.  Sometimes we are quick to point the fingers at the device or at our DAC or at Jriver or.... but here was a case where an OS permission was lacking - not sure why however.  Just sharing the knowledge.

 

Regarding the question of how I use the microRendu - I use it the simplest way = via DLNA in JRiver controlled by an iPAD with the music residing in an SSD within the PC.  So, No Roon, no HQ Player, no NAS.  The next step for me will be NAS however (I want to move all music and non-music shared files in my home network off the PC) and then probably eventually Roon - I was reluctant to go Roon until I was convinced they will be here for the duration :) 

 

JM

 

I don't quite follow what @JMotzi referred to in the two bold sections above (I'm not seeing what he describes in Control Panel / Explorer), but would that be relevant to my Spotify connect issue?  

 

Share this post


Link to post
Share on other sites

Hi, I bought the microrendu 1st may 2017, very pleased. Two weeks later spotify stoped working and took till the 10th June to get a fix. Am now having same issues.

Have tried updating a few mins ago but still not functioning.

Could you please go through update procedure in case i'm doing something wrong

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×