Jump to content
Computer Audiophile
scan80269

USB Audio 2.0 Class Driver in latest Windows 10 RS2

Rate this topic

Recommended Posts

The latest Microsoft Windows 10 Creators Update (a.k.a. Redstone2 or RS2) includes a new USB Audio 2.0 class driver, usbaudio2.sys.  This driver is an alternative to supplier-provided drivers for USB DACs.

 

I've tried running a few of my USB DACs with this OS and driver and they all seem to work properly, though unlike many supplier-provided drivers, the MS USB Audio 2.0 class driver does not appear to expose any user controls, such as buffer size.  When running a USB DAC with this inbox driver, I noticed there is an extra USB endpoint device, typically named "<DAC name> DFU".  For example, with my Cambridge Audio DACMagic XS, a "CA DFU" device shows up in Device Manager with a yellow bang.  I'm pretty sure this is a USB endpoint intended to support firmware updates (DFU = device firmware update) and can be safely ignored, though having a perpetual yellow bang device in Device Manager is a nuisance.

 

I have yet to do sonic comparisons between supplier-provided driver and this MS inbox USB Audio 2.0 class driver for the same DAC HW, but hope to get to this soon.

 

Share this post


Link to post
Share on other sites
2 hours ago, Dr Tone said:

What formats did you try?  PCM, DSD DOP etc?

Using the Microsoft USB Audio 2.0 driver with my Holo Audio Spring DAC, I successfully played PCM up to 384K, and up to DSD256 DoP..  I tested with HQPlayer in WASAPI mode, since this driver has no ASIO functionality.

 

Share this post


Link to post
Share on other sites

Win10 Creators  Update is expected to become downloadable from Windows Update starting on April 11.

 

I've successfully completed the OS update manually for several PCs, but on my ultrabook, access to files on a mapped network drive over wireless got badly messed up. I rolled back to Win10 RS1 to restore the functionality.  Not sure why only one PC was affected though.

 

Share this post


Link to post
Share on other sites
CatManDo   

For my M2Tech Hiface Two USB converter, I replaced the M2Tech driver with the Microsoft driver.

 

At first, it seemed to work fine. I can play files (24/96 PCM) with Foobar2000, I hear sound.

 

But some things didn't work right. The track progress bar was stuck and didn't react, i.e. impossible to navigate within a track. The visualisations in Foobar2000 (VU meter, spectrum meter) didn't work.

 

I switched back to the M2Tech driver.

Edited by CatManDo

Share this post


Link to post
Share on other sites
Fairy   
On 9-4-2017 at 5:29 PM, CatManDo said:

For my M2Tech Hiface Two USB converter, I replaced the M2Tech driver with the Microsoft driver.

 

At first, it seemed to work fine. I can play files (24/96 PCM) with Foobar2000, I hear sound.

 

But some things didn't work right. The track progress bar was stuck and didn't react, i.e. impossible to navigate within a track. The visualisations in Foobar2000 (VU meter, spectrum meter) didn't work.

 

I switched back to the M2Tech driver.

 

I've got a CM6631A based USB>SPDIF unit based on USB class 2 and ik works perfect now. With the original driver I got nasty pops and clicks when switching between songs. When switching during a loud passage the buffer seems to be filled when switching so a loud click appears.

 

With this new driver it works perfect. In Event mode WASAPI I got the same problem you have. It does play but no visuals. In Push mode everything works fine. I already used push mode because event mode gave the loudest clicks/pops.

 

I'm very happy with this native driver!

Edited by Fairy

Share this post


Link to post
Share on other sites
blue2   

Oops spoke too soon! The "disable all sound effects" option has been removed (Control Panel > Sound > select Playback device > Properties > Enhancements tab) so it seems that Windows interferes (resamples) with your sound output and there is no way to avoid it! The only thing you can do is chose the same output format as your track to avoid resampling!

It seems MS are now only rolling out the Creators Update to new machines as there are so many issues.

Share this post


Link to post
Share on other sites
Fairy   
16 minutes ago, blue2 said:

Oops spoke too soon! The "disable all sound effects" option has been removed (Control Panel > Sound > select Playback device > Properties > Enhancements tab) so it seems that Windows interferes (resamples) with your sound output and there is no way to avoid it! The only thing you can do is chose the same output format as your track to avoid resampling!

It seems MS are now only rolling out the Creators Update to new machines as there are so many issues.

 

That's not a problem. These only apply to DirectSound. WASAPI bypasses all this. By the way. There is another tab now, which also mentions the Atmos. I see no problem with WASAPI playback. I've tested this at my DDC and it mentions the right samplerate of the file beeing played.

Edited by Fairy

Share this post


Link to post
Share on other sites
blue2   
2 hours ago, Fairy said:

 

That's not a problem. These only apply to DirectSound. WASAPI bypasses all this. By the way. There is another tab now, which also mentions the Atmos. I see no problem with WASAPI playback. I've tested this at my DDC and it mentions the right samplerate of the file beeing played.

You might be lucky with your setup. I have a T+A DAC 8 DSD using the T+A driver and it affects my system.

Share this post


Link to post
Share on other sites
rickca   
5 hours ago, blue2 said:

Oops spoke too soon! The "disable all sound effects" option has been removed (Control Panel > Sound > select Playback device > Properties > Enhancements tab) so it seems that Windows interferes (resamples) with your sound output and there is no way to avoid it! The only thing you can do is chose the same output format as your track to avoid resampling!

It seems MS are now only rolling out the Creators Update to new machines as there are so many issues.

It's still there.  I'm running Creators Update and there is still a 'Disable all enhancements' check box on the Enhancements tab.  Is that what you're looking for?

Share this post


Link to post
Share on other sites
Fairy   
2 hours ago, rickca said:

It's still there.  I'm running Creators Update and there is still a 'Disable all enhancements' check box on the Enhancements tab.  Is that what you're looking for?

I was checking on my pc at work. There the button is gone. On my home laptop it is still there. Probably on some occasions the option is gone. However there is no need to worry. You can set the disable checkbox, but when there is no enhancement activated it does absolutely nothing.

Share this post


Link to post
Share on other sites
blue2   
2 hours ago, Fairy said:

I was checking on my pc at work. There the button is gone. On my home laptop it is still there. Probably on some occasions the option is gone. However there is no need to worry. You can set the disable checkbox, but when there is no enhancement activated it does absolutely nothing.

Yes that's what I'm talking about and as I said I have a T+A DAC 8 DSD which Windows has decided shouldn't have the 'enhancements' tab, hence the problem. The tab does appear for other audio outputs on the same machine.

 

So the result is that Windows Creators Update forces my audio through its resampler which I don't want. It lists all the replay formats correctly up to 384KHz on the Advanced tab but only up to 192KHz on the Supported Formats tab. 

Share this post


Link to post
Share on other sites
Fairy   
12 hours ago, blue2 said:

Yes that's what I'm talking about and as I said I have a T+A DAC 8 DSD which Windows has decided shouldn't have the 'enhancements' tab, hence the problem. The tab does appear for other audio outputs on the same machine.

 

So the result is that Windows Creators Update forces my audio through its resampler which I don't want. It lists all the replay formats correctly up to 384KHz on the Advanced tab but only up to 192KHz on the Supported Formats tab. 

 

Correct me if I'm wrong, but this is correct behavior AFAIK. 192kHz is supported via SPDIF. 384kHz is only supported via I2S connection. Possibly this is only possible via WASAPI. Could that be the case?

 

My DSD DDC is on it's way via plane to me, so I cannot check yet. my current DDC only supports 192kHz and is broken unfortunately...

 

My NAD C388 takes SPDIF coax, so I'm limited to 192kHz already, but I don't see any problem with that. 16 bit 44.1kHz is fine for me. I feed the C388 exactly the source signal and it sounds absolutely great.

Edited by Fairy

Share this post


Link to post
Share on other sites
CatManDo   
47 minutes ago, Fairy said:

 

Correct me if I'm wrong, but this is correct behavior AFAIK. 192kHz is supported via SPDIF. 384kHz is only supported via I2S connection. Possibly this is only possible via WASAPI. Could that be the case?

 

But is this relevant for a USB driver?

Share this post


Link to post
Share on other sites
Fairy   
2 hours ago, CatManDo said:

 

But is this relevant for a USB driver?

 

Do you have a device that supports 384kHz? If so, try via WASAPI. I cannot test it for you. I'm "limited" to 192kHz.

Share this post


Link to post
Share on other sites
blue2   

Thanks for all the suggestions. I've solved it and it's not a Windows Creators Upgrade USB problem after all, it's the foobar2000 set up which was wrong. I had the T+A driver as output and no foo_out_asio component. Once I installed this the T+A driver becomes "DS: T+A driver" in the output list, and you then choose the driver from the new configuration sub-item ASIO. DS is DirectSound which uses the Windows audio stack, hence the resampling problem.

 

Phew! Sorry for the confusion.

Share this post


Link to post
Share on other sites
Fairy   
1 hour ago, blue2 said:

Thanks for all the suggestions. I've solved it and it's not a Windows Creators Upgrade USB problem after all, it's the foobar2000 set up which was wrong. I had the T+A driver as output and no foo_out_asio component. Once I installed this the T+A driver becomes "DS: T+A driver" in the output list, and you then choose the driver from the new configuration sub-item ASIO. DS is DirectSound which uses the Windows audio stack, hence the resampling problem.

 

Phew! Sorry for the confusion.

 

Good to hear the problem is solved and thanks for the feedback.

Edited by Fairy

Share this post


Link to post
Share on other sites

Hi,

I was hoping to be able to go to windows 10 finally. However, the USB Audio output from Win 10 is inferior to Win 7 with M2tech drivers for Hiface two.

I play music on the PC via USB over to Hiface Two connected over BNC to Exposure 2010S2 DAC and 2x Exposure 3010S2 Mono Power Amplifiers driving speakers Monitor Audio Gold 300.

I compared Linux, Mac, Win 10 creators update, Win 10 with m2tech driver and Win 7 with m2tech driver.

All are noticably worse comparing to Win7 with m2tech drivers. I wonder why Win10 with m2tech drivers does not play as good as win7. It must be down to M2tech really spending most of their R&D on Windows 7 when building the product

Share this post


Link to post
Share on other sites
lmitche   
2 hours ago, peter.imrich said:

Hi,

I was hoping to be able to go to windows 10 finally. However, the USB Audio output from Win 10 is inferior to Win 7 with M2tech drivers for Hiface two.

I play music on the PC via USB over to Hiface Two connected over BNC to Exposure 2010S2 DAC and 2x Exposure 3010S2 Mono Power Amplifiers driving speakers Monitor Audio Gold 300.

I compared Linux, Mac, Win 10 creators update, Win 10 with m2tech driver and Win 7 with m2tech driver.

All are noticably worse comparing to Win7 with m2tech drivers. I wonder why Win10 with m2tech drivers does not play as good as win7. It must be down to M2tech really spending most of their R&D on Windows 7 when building the product

Give AudiophileOptimizer on win 10 a try.  You are likely to be pleasantly surprised.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×