Page 5 of 46 FirstFirst 12345678915 ... LastLast
Results 101 to 125 of 1140
  1. #101
    Newbie
    Join Date
    Aug 2015
    Location
    Singapore
    Posts
    6
    Quote Originally Posted by kit1cat View Post
    Did you update your database in moode, and try a reboot of your pi?
    Yes I tried both. Update the folder, as well as a reboot of P2. Cover art not found. I place the folder.jpg in same folder as the songs.

    I am running moode 2.1.

  2. #102
    Quote Originally Posted by U2nite View Post
    Yes I tried both. Update the folder, as well as a reboot of P2. Cover art not found. I place the folder.jpg in same folder as the songs.

    I am running moode 2.1.
    Strange, it seems to work for some people and not others. Perhap's Tim can shed some light on the problem. Do you have album art lookup method set to default in moode customization screen?

  3. #103
    Newbie
    Join Date
    Aug 2015
    Location
    Singapore
    Posts
    6
    Quote Originally Posted by kit1cat View Post
    Strange, it seems to work for some people and not others. Perhap's Tim can shed some light on the problem. Do you have album art lookup method set to default in moode customization screen?
    kit1cat, Thanks for your pointer.

    Yes album art is working for me now.

    Customise > Album Art lookup = default.
    Album art renamed as folder.jpg in the album folder.
    I did a MPD database update.

    Now enjoying the excellent music and album art

  4. #104
    Quote Originally Posted by U2nite View Post
    kit1cat, Thanks for your pointer.

    Yes album art is working for me now.

    Customise > Album Art lookup = default.
    Album art renamed as folder.jpg in the album folder.
    I did a MPD database update.

    Now enjoying the excellent music and album art

    Well Done :-)

  5. #105
    Quote Originally Posted by thisisvv View Post
    Hi,

    I'd b pleasantly surprised if Moode image ran on this board :-) but I don't think it will because the board probably requires a non-mainline kernel that is compiled with whatever support and drivers it needs. Just guessing.

    Regards,
    Tim

  6. #106
    Hi,

    For PCM audio, under "Input Processing", the bit rate is going to be less than the "Output Stream" bit rate when the input is a compressed format (FLAC, ALAC, MP3, etc.). For compressed audio formats, the bit rate represents the amount of compression rather than bit-depth x sample-rate x #channels.

    I think we are stuck with USB(UAC2) issues for a while until the Linux USB guy gets a chance to work on the driver. Maybe there will be something in one of the 4.x Linux kernels. I'll be watching :-)

    I'll add the Burson device to audio device db so you can select it in Customize popup.

    (1) Which DAC chip are u using in the Burson, ES9018 or PCM1793 ?
    (2) The product name is "Burson Conductor Virtuoso" correct?

    Regards,
    Tim

  7. #107
    Quote Originally Posted by PeteP View Post
    Dear Tim,

    The addition of "dwc_otg.fiq_fsm_mask=0x3" is OK. No longer just noise from DAC! I play for 1 hour without any cracks/clips, so that's fine. I like to do a real A-B comparison later.

    I tried to play SACD and high resolution flac (3mbps/96kHz). This results in many cracks. I made the following observations:
    1) From the "Audio information" I conclude the bitrate is changed (input +- 3mbps, output +- 4mpbs)
    2) From the "Customization section" the audio device is empty as my Burson Conductor is not in the list.
    Do you have a solution for my problem?

    Thanks in advance
    Pete
    Hi,

    For PCM audio, under "Input Processing", the bit rate is going to be less than the "Output Stream" bit rate when the input is a compressed format (FLAC, ALAC, MP3, etc.). For compressed audio formats, the bit rate represents the amount of compression rather than bit-depth x sample-rate x #channels.

    I think we are stuck with USB(UAC2) issues for a while until the Linux USB guy gets a chance to work on the driver. Maybe there will be something in one of the 4.x Linux kernels. I'll be watching :-)

    I'll add the Burson device to audio device db so you can select it in Customize popup.

    (1) Which DAC chip are u using in the Burson, ES9018 or PCM1793 ?
    (2) The product name is "Burson Conductor Virtuoso" correct?

    Regards,
    Tim

  8. #108
    Hi Tim,

    All of sudden without making any change to my configuration I have a new problem. Rebooting the PI and/or DAC in any order has no influence.
    I can browse and select a song. The UI shows the selected song. However:
    - playback does not start or is ended in a split second.
    - volume cannot be changed, UI will show to change it to 50 or 100%, but it will instantly return to the 0 postilion.
    I got the impression it does not respond on the DAC too. As normally I hear a click (relais?) on the DAC when starting up or change to HR.

    Please share your thoughts on this.
    Thanks
    Pete
    Last edited by PeteP; 08-22-2015 at 03:17 AM.

  9. #109
    Quote Originally Posted by tcmods View Post
    Hi,

    For PCM audio, under "Input Processing", the bit rate is going to be less than the "Output Stream" bit rate when the input is a compressed format (FLAC, ALAC, MP3, etc.). For compressed audio formats, the bit rate represents the amount of compression rather than bit-depth x sample-rate x #channels.

    I think we are stuck with USB(UAC2) issues for a while until the Linux USB guy gets a chance to work on the driver. Maybe there will be something in one of the 4.x Linux kernels. I'll be watching :-)

    I'll add the Burson device to audio device db so you can select it in Customize popup.

    (1) Which DAC chip are u using in the Burson, ES9018 or PCM1793 ?
    (2) The product name is "Burson Conductor Virtuoso" correct?

    Regards,
    Tim

    Tim,

    I have the Conductor with ES9018. The Virtuoso is a new model, same DAC.
    Does the addition of the Burson to the Customize popup change the behavior or Moode or is it merely a cosmetic upgrade?

    Concerning the SACD and HR playback results of continuous cracks, I like to share the following. On a Banana Pi -
    Linux bananapi 3.4.104+ I run currently squeezelite. The squeezelite does playback HR files.
    My problem with squeezelite is that I have every few minutes a crack, independent from the audio format. So this does not fully meet my requirements.
    MooDe did so far produce
    not any cracks on plain FLAC but could not produce 2 seconds of HR audio without cracks.
    Can you share your thought on this? Has Linux 3.18 (MoOde) more problems than Linux 3.4?

    Thanks
    Pete

  10. #110
    Quote Originally Posted by PeteP View Post
    Hi Tim,

    All of sudden without making any change to my configuration I have a new problem. Rebooting the PI and/or DAC in any order has no influence.
    I can browse and select a song. The UI shows the selected song. However:
    - playback does not start or is ended in a split second.
    - volume cannot be changed, UI will show to change it to 50 or 100%, but it will instantly return to the 0 postilion.
    I got the impression it does not respond on the DAC too. As normally I hear a click (relais?) on the DAC when starting up or change to HR.

    Please share your thoughts on this.
    Thanks
    Pete
    Hi Pete,

    The symptoms suggest either a hardware related comms issue between DAC and Linux/USB or possibly a corrupt SD Card. I would recommend swapping out one of the following.

    (a) USB cable
    (b) Power supply
    (c) SD Card

    Each of the above have come up in troubleshooting sessions with users. I personally experienced almost the exact same symptoms that you describe and it turned out to be a bad USB cable.

    Regards,
    Tim

  11. #111
    Quote Originally Posted by PeteP View Post
    Tim,

    I have the Conductor with ES9018. The Virtuoso is a new model, same DAC.
    Does the addition of the Burson to the Customize popup change the behavior or Moode or is it merely a cosmetic upgrade?

    Concerning the SACD and HR playback results of continuous cracks, I like to share the following. On a Banana Pi -
    Linux bananapi 3.4.104+ I run currently squeezelite. The squeezelite does playback HR files.
    My problem with squeezelite is that I have every few minutes a crack, independent from the audio format. So this does not fully meet my requirements.
    MooDe did so far produce
    not any cracks on plain FLAC but could not produce 2 seconds of HR audio without cracks.
    Can you share your thought on this? Has Linux 3.18 (MoOde) more problems than Linux 3.4?

    Thanks
    Pete
    Hi Pete,

    Thanks! I'll add it to the device description db.

    Here are answers to your questions:

    (1) Does the addition of the Burson to the Customize popup change the behavior or Moode or is it merely a cosmetic upgrade?


    It's strictly cosmetic and used only for displaying the nice device info on the Audio Information popup.

    (2) Can you share your thought on this? Has Linux 3.18 (MoOde) more problems than Linux 3.4?

    "Linux giveth and Linux taketh away" is what I would say. The 3.18 kernels bring a lot of goodness but also some pain. Below is the issue posted to Github in March 2015 and the USB guy's conclusion after testing UAC2 chipset based DAC with a hardware USB analyzer "Yep, it's broken".

    USB Audio broken in kernel 3.18.7+ #888
    https://github.com/raspberrypi/linux/issues/888


    Regards,
    Tim Curtis

  12. #112
    Quote Originally Posted by tcmods View Post
    Hi Pete,

    The symptoms suggest either a hardware related comms issue between DAC and Linux/USB or possibly a corrupt SD Card. I would recommend swapping out one of the following.

    (a) USB cable
    (b) Power supply
    (c) SD Card

    Each of the above have come up in troubleshooting sessions with users. I personally experienced almost the exact same symptoms that you describe and it turned out to be a bad USB cable.

    Regards,
    Tim
    Hi Tim

    Thanks.
    I tried to:
    1) use less power by removing HD disk from system and added some music to flash memory. I was not able to browse the SD card content. Can you tell me how to access this?
    2) use the same power supply and HD for the Bananpi configuration. Everything runs smoothly. So that ain't t the problem, although bananapi might use a little less power.

    Best regards
    Pete

  13. #113
    Quote Originally Posted by PeteP View Post
    Hi Tim

    Thanks.
    I tried to:
    1) use less power by removing HD disk from system and added some music to flash memory. I was not able to browse the SD card content. Can you tell me how to access this?
    2) use the same power supply and HD for the Bananpi configuration. Everything runs smoothly. So that ain't t the problem, although bananapi might use a little less power.

    Best regards
    Pete
    Hi Pete,

    After adding the song files to SD Card did u run UPDATE MPD DB from Source config screen?

    Regards,
    Tim

  14. #114
    Quote Originally Posted by tcmods View Post
    Hi Pete,

    After adding the song files to SD Card did u run UPDATE MPD DB from Source config screen?

    Regards,
    Tim
    Dear Tim,
    I did.
    First in /audio. Next moved them to /media. Next moved them to /media/usb0 (just folder, no device).
    No success...

    BR,
    Pete

  15. #115
    Quote Originally Posted by PeteP View Post
    Dear Tim,
    I did.
    First in /audio. Next moved them to /media. Next moved them to /media/usb0 (just folder, no device).
    No success...

    BR,
    Pete

    After you have used the option in moode config to expand the sd card, you should have a folder called \\Moode\sdcard on the sd card, copy your music files to this folder then update the database. I used file manager in windows to copy music files from windows to my pi sd card. You will find moode under network in windows file manager. Hope this helps, it worked for me.

  16. #116
    I like this software but I'm struggling to get it to recognise my NAS, the IP address is 192.168.0.15 and the name is goflex home, the path is public/music but I can't seem to get the software to find the nas, any suggestions?

  17. #117
    Quote Originally Posted by despearce View Post
    I like this software but I'm struggling to get it to recognise my NAS, the IP address is 192.168.0.15 and the name is goflex home, the path is public/music but I can't seem to get the software to find the nas, any suggestions?
    Hi,

    What's in the following fields on Source config screen:

    Source name:
    Fileshare protocol:
    Remote directory:

    Regards,
    TC

  18. #118
    Music
    smb/cifs
    Public/music

  19. #119
    Quote Originally Posted by despearce View Post
    Music
    smb/cifs
    Public/music
    Hi,

    Symptoms "can't connect to GoFlex share" suggest one of the following based on what I read in various forum posts.

    (1) Moode "Remote directory" path incorrect
    (2) GoFlex 5 computer connect limit exceeded
    (3) Need to add "sec=ntlm" to Moode mount flags

    Below is a mount string that I ran across in a forum post.

    mount -t cifs ‘//192.168.XX.YY/GoFlex Home Public’ /home/pi/goflex/public -o username=blahblah,password=blahblah,iocharset=utf8 ,file_mode=0777,dir_mode=0777,sec=ntlm

    First thing I would try is "GoFlex Home Public" for the entry in Moode "Remote directory" field. If still no-go then try adding "sec=ntlm" to the Moode mount flags.

    Regards,
    Tim C

  20. #120
    Quote Originally Posted by tcmods View Post
    Hi,

    Symptoms "can't connect to GoFlex share" suggest one of the following based on what I read in various forum posts.

    (1) Moode "Remote directory" path incorrect
    (2) GoFlex 5 computer connect limit exceeded
    (3) Need to add "sec=ntlm" to Moode mount flags

    Below is a mount string that I ran across in a forum post.

    mount -t cifs ‘//192.168.XX.YY/GoFlex Home Public’ /home/pi/goflex/public -o username=blahblah,password=blahblah,iocharset=utf8 ,file_mode=0777,dir_mode=0777,sec=ntlm

    First thing I would try is "GoFlex Home Public" for the entry in Moode "Remote directory" field. If still no-go then try adding "sec=ntlm" to the Moode mount flags.

    Regards,
    Tim C
    Many thanks Tim, I had tried "goflex home public" with no luck but the "sec=ntlm" sorted it. Running now and playing Redbook and Hires files, sounds great as well. I'll be suggesting this to other people who use a Pi with I2S dac as a streamer....

  21. #121
    Quote Originally Posted by despearce View Post
    Many thanks Tim, I had tried "goflex home public" with no luck but the "sec=ntlm" sorted it. Running now and playing Redbook and Hires files, sounds great as well. I'll be suggesting this to other people who use a Pi with I2S dac as a streamer....
    Hi,

    Glad to hear that worked :-)

    Regards,
    Tim

  22. #122
    Hi,

    Moode Audio Player release 2.2 is available for download at moodeaudio.org :-)

    This release includes the wonderfully engineered shairport-sync Airplay receiver for synchronized multi-room audio, a universal Album Art display module that supports embedded cover images in FLAC and MP3 files as well as local cover image files, USB 2x current setting for non-powered USB HDD's, and support for Rotary Encoder and IR based based volume controls using IQaudIO's excellent device drivers and a Moode volume knob cli.

    The shairport-sync implementation in Moode automatically uses hardware volume control if it is supported by the audio device and configured in MPD config settings. This provides fast response for play/pause and volume change actions.

    Also included in this release is the excellent WiringPi GPIO interface, fully automated configuration of PCM 5122 on-chip analog volume controls for IQaudIO+ and other PCM 5122 based audio devices, additional audio device descriptions and a few nice bug fixes.

    Lastly, check out the great set of new listener supported, commercial free radio stations most of which are based in Australia! and please note the nice code contributions from the developer community :-)

    Enjoy!

    Regards,
    moodeaudio.org
    Moode Twitter Feed
    Tim Curtis

    ======================
    2.2 Release 2015-08-30
    ======================

    New features

    - NEW: Synchronized multi-room audio via Shairport-sync Airplay receiver
    - NEW: Display album art embedded in FLAC and MP3 audio files
    - NEW: Serve album art to MPoD/MPaD clients (url=http://moode)
    - NEW: USB 2x current setting for improved support of non-powered USB storage devices
    - NEW: Automatic configuration of PCM5122 on-chip analog volume ctrls
    - NEW: WiringPi GPIO interface for control of GPIO pins
    - NEW: Rotary encoder and IR device device drivers from IQaudIO
    - NEW: Volume knob cli for external application control of volume

    Media

    - NEW: 2BOB Radio 104.7 FM
    - NEW: 4ZZZ FM 102.1 - Alternative
    - NEW: ABC Country
    - NEW: ABC Jazz
    - NEW: ArtSound FM 92.7
    - NEW: Radio Monash
    - NEW: SUB.FM - Where Bass Matters
    - NEW: Triple J
    - NEW: Triple J Unearthed
    - NEW: True Vinyl Radio
    - NEW: UCFM 87.8 - Canberra's Alternative

    Updates

    - UPD: Improved logic for making text that populates MPD Audio output field
    - UPD: AudioQuest DragonFly, Burson Conductor and TEAC UD-501 added to audio device db
    - UPD: Cyenne Audio CY-3100, CY-3100SE and CY-5100dsd MK-II added to audio device db
    - UPD: Contrib for Mike Brady, author of shairport-sync Airplay receiver
    - UPD: Contrib for Gordon Henderson, author of WiringPi GPIO interface
    - UPD: Contrib for Gordon Garrity, author of IQ_rot and IQ_ir device drivers
    - UPD: Contrib for Andreas Goetz, Moode 3 project, 2.2 coverart, MPoD/MPaD support and bugfixes

    Bug fixes

    - FIX: Duplicate Artists listed in Library panel when artist belongs to multiple Genres
    - FIX: Song duration not appearing for song files in Playlist
    - FIX: HTTP reference link on System config page not opening in seperate tab
    - FIX: MPD volume not being set to 0 for mixer type "disabled" prior to MPD restart


    Attached Thumbnails Attached Thumbnails player-1.png   rotary-enc.png   moode-r22-radio-mosaic.png  


  23. #123
    Is it possible to have two players running Moode on the same network? Would one ave to be connected, renamed and rebooted and then the second one started and added?

  24. #124
    Quote Originally Posted by despearce View Post
    Is it possible to have two players running Moode on the same network? Would one ave to be connected, renamed and rebooted and then the second one started and added?
    Hi,

    Yes. Rename and reboot the first one, then boot the second one which will have the default host name "moode", then rename and reboot it.

    The player name (host name) and other names can be changed on the System config page. See attached screen shot. Press the SET button after entering each new name, then one reboot and you should be all set. Note that three of the name fields: Airplay receiver, UPnP renderer and DLNA server also have an ON/OFF toggle for the service.

    Regards,
    Tim Curtis
    Attached Thumbnails Attached Thumbnails system-cfg1.png  

  25. #125

    v2.2 album art is fab

    Much much thanks on v2.2...I came from Volumio a while ago... that took 3.5hrs to scan my 11k library... Moode takes 3.5 *minutes*, so a reflash/upgrade is nice and quick & easy!

    Now that the album art works in the Android apps (MPDroid/MuPeace etc), this is PERFECT.

    I just donated.

    Thanks again!

Page 5 of 46 FirstFirst 12345678915 ... LastLast

LinkBacks (?)

  1. 03-21-2015, 11:02 PM